« スピーカー買いました。 | トップページ | JSPのコンパイルができなくなりハマる »

2005/08/12

EclipseのLombozプラグインのインストールでハマる

前に、漫画ビューアをJAVAのアプレットで作ったのですが、その際にEclipseを使ってみてビックリ。すごすぎ!!
テキストエディタのみでガリガリ書くのとは作業効率が全く違います。
こんなスゴいソフトがタダで使えるなんて!って感動したもんです。

そのEclipse、プラグインをインストールすればWebアプリケーション作成にも使えるってんで、本を読んで試してみることにしました。
「オープンソース徹底活用 Eclipse3によるJavaアプリケーション開発」ってな本です。
それによると、LOMBOZ というJ2EE開発用のプラグインがあるそうです。

早速本に書いてあるとおりにプラグインをインストールしました。
インストールといっても plugins のフォルダに追加するだけなんですけどね。

で、Eclipseを起動してみたのですが・・・。設定項目がない・・・・・。
本には、設定画面でLombozの項目を選択できることになっているのですが、項目がありません。

本の環境と自分の環境はほぼ同じで、
Eclipse3.0.1 TOMCAT5.0.28 Lomboz3.0.1です。
唯一違うのがJavaで、
本では1.4を使っているのに対し、5を使っています。
そんなわけで、LombozがJava5に対応していないのではないか?と思って、Java1.4を入れてみましたが、状況は変わりません。

本の出版社のページにも行ってみたのですが、正誤表も無いようです。

ネットでいろいろ調べたのですが、だいたい本に載っているようなインストール方法で大丈夫みたいです。
いったい何が原因なんだろう???

もう少し調べた所、「Javaの道」に解決策が載っていました
Lombozを使用する時は、EMF&SDOのRuntimeもインストールする必要があるそうなんです。
で、「Javaの道」に書いてあるとおりにインストールした所、ちゃんと設定できるようになりました。
やった~。

ですが、本の説明どおりに設定したのにうまくいかなかったのにはまいりました。
出版社のページに正誤表が無いので、もしかしたら、本の書いてある順番にいろんなプラグインをインストールしていけばうまくいくのかもしれません。

ちなみにJavaは5に戻しましたが、問題なく動いています。(汗)

|

« スピーカー買いました。 | トップページ | JSPのコンパイルができなくなりハマる »

Eclipse」カテゴリの記事

JAVA」カテゴリの記事

Tomcat」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/54336/5426405

この記事へのトラックバック一覧です: EclipseのLombozプラグインのインストールでハマる:

« スピーカー買いました。 | トップページ | JSPのコンパイルができなくなりハマる »