« Ubuntu11.04へアップグレードする | トップページ | UbuntuにOpenVPNを導入する »

2011/07/09

VMwareのUbuntuサーバにNHMを設定したらネットにつながらなくてハマる

社内サーバのテスト環境を作ろうと思い、Ubuntu Server 8.04をVMware上にインストールしました。

で、いろいろテストすることも考えてスナップショットが使えるようにNHMへ設定した所、ネットワークに繋げませんでした。
$ sudo /etc/init.d/networking restart
としても、「No such device」 と出てきます。
デバイスを認識してないのか!?

しかし、Ubuntuのデスクトップ版はNHMを使っても全然問題ないし、そもそもVMware上のNICを認識できていないなんてことはありえないです。

ネットで調べてみたところ、やぱりハマっている人はたくさんいました。

原因は、udevでした。
VMwareのイメージをコピーするとMACアドレスが変わりますが、Ubuntu Server はインストール時に
MACアドレスとインターフェースの関連付けを udev に登録してしまうのだそうです。
そんなわけで、違うMACアドレスのNICを見つけると、違うインターフェースへ登録していくのだそうです。

解決法として、/etc/iftab を修正する、というのがあったのですが、Ubuntu Server 8.04 にはそんなファイルはありません。
もう少し調べると、最近のUbuntuは /etc/udev/rules.d/70-persistent-net.rules に設定されているそうです。

参考にしたのは、以下のページです。
Yet Another Diary vmwareでclone化したUbuntu 8.04でeth0がeth1になってしまう
ある異邦人の技術メモ Ubuntu 7.10を違うマシンにHDDごと移動したときのネットワーク設定

LANCARD.LAB VMware で Ubuntu イメージをコピーしたら NIC が見えなくなる件

やった内容ですが、
$ ifconfig -a
で、 eth1 ができてしまっていることを確認。

/etc/udev/rules.d/70-persistent-net.rules
の eth0 の設定を削除し、eth1 をeth0 に修正。

で、再起動したらネットにつながるようになりました。


なぜデスクトップ版にはこのような問題が起こらないのか疑問に思い、
70-persistent-net.rule ファイルを見たところ、なんとそこにはコメントだけで何も記述されていませんでした。
また、/etc/udev/rules.d/75-persistent-net-generator.rules ファイルがそもそもありませんでした。

|

« Ubuntu11.04へアップグレードする | トップページ | UbuntuにOpenVPNを導入する »

Ubuntu」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/54336/52159927

この記事へのトラックバック一覧です: VMwareのUbuntuサーバにNHMを設定したらネットにつながらなくてハマる:

« Ubuntu11.04へアップグレードする | トップページ | UbuntuにOpenVPNを導入する »