« 2018年11月 | トップページ

2019年5月

2019/05/03

PC-LL750RG に Ubuntu18.04LTS をインストールしてハマる

実家からもらった NECのノートパソコン LaVie L LL750/RG 型番 PC-LL750RG なんですが、メモリーが4Gありました。
子供がフレバーじゃない素のUbuntuを使ってみたいと言ってるし、Core 2 Duo で メモリ4Gあったら、普通のUbuntuでもサクサクじゃんね。と思って、Ubuntu18.04LTS を入れることにしました。

日経Linuxの2018年7月号の付録に、豪華なパッケージに入ってたインストールDVDあったなあと思い、今こそ使うときと思ってインストールを進めました。

・・・ところが、インストール用のDVDが途中で止まってしまうのです。
drm_kms_helper が flip_done timed out ってERROR 吐いて止まってしまいます。
ネットで調べた所、こんなページを見つけました。
ubuntu forums Issue with KMS / Xorg with Intel GM965 chipset
かなり古い記事ですが、症状は似ています。
PC-LL750RG も Intel GM965 チップセットだからなあ。
GRUBのカーネルパラメータに video=SVIDEO-1:d を設定したらOKだったとのことなので、インストール用のDVD起動時にカーネルパラメータに
video=SVIDEO-1:d
を追加して起動したら、正常にインストーラが起動して、インストールも正常に終了しました。
インストーラ起動時の選択画面でeキー押したら設定ファイルが表示されるので、 quiet splash という文字をたよりにカーネルパラメータの場所を特定し、 video=SVIDEO-1:d を追加する流れです。

が、インストールした Ubuntu18.04LTS を起動すると当然同じ症状が発生します。
すごく待たされますが、いちおうログインしてデスクトップが表示される所までは行くので、GRUBのカーネルパラメータを追加することになります。
やり方は、ここの記事が詳しかったです。
Ask Ubuntu Boot very slow because of drm_kms_helper errors

sudo nano /etc/default/grub
でGRUBの設定ファイルを開いて、
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
みたいな感じでカーネルパラメータに video=SVIDEO-1:d を追加。
sudo update-grub
で設定を反映して、再起動、という流れです。

これで正常に起動するようになりました。

このカーネルパラメータの意味に興味があったので調べた所、以下の記事がありました。
archlinux Intel Graphics
詳しくは解らないのですが、チップセットのドライバだかなんだかが、いまだに低解像度のSVIDEO関連の設定を持っているものだから、これを明示的に無効にするようにしなければいけないという所なんでしょうか。


トラブったけど、その後Ubuntuは問題無く動いています。
普段 UbuntuMATE を使っているので知らなかったのですが、Ubuntuソフトウェア では Urban Terror とかのゲームがSnapパッケージになっているんですね。
この前にUbuntuMATEに入れようとしてパッケージ無いからオフィシャルからダウンロードしたっけなあ。
Snapだったらインストール簡単だしらくちんだよなあ。
Minecraft も ランチャーをSnapパッケージにしてくれているし、しかも内包されているJavaのバージョンが11ではなく8なのには感動しました。
8でないと外部サーバにうまく繋がらないバージョンがあるんですよ。
パッケージャの人!よく解ってる!!

| | コメント (0)

2019/05/02

PC-LL750RG の修理

実家で使っていたパソコンの電源が入らなくなったとのことで、貰ってきました。

機種は、NECのノートパソコン LaVie L LL750/RG 型番 PC-LL750RG です。

電源スイッチを押してもうんともすんとも言わないので、電源周りかと思いアダプターをテスターで調べたら通電していない。

 

そこで代替のアダプターを買ってきました。ELECOMの ACDC-NE1500BK です。

アダプターを繋ぐと、充電ランプが付いたのでOKです。

早速パソコンを起動したのですが、起動しているようなのだけど画面が真っ暗。

よーく見ると、うっすらと画面が表示されています。

うわー。バックライトか。これはダメなやつかも。

デュアルディスプレーにしたら使えるかもと思い、モニターを繋いだらモニターではちゃんと映ります。

この運用で使うか、とも思いましたが、そもそもOS起動しないとモニターには何も映らないので、OS入れ替えとかできないじゃん・・・。

やっぱ、画面映らないとだめだよなあ・・・と思いつつ何度か触っているうちに、正常に画面が表示されるようになりました。

直った????と思って一旦シャットダウンし、再度起動するとやっぱり画面が真っ暗のまま起動する。

でも正常に表示される場合があったということは、バックライトの問題ではなさそうです。

 

訳が解らずネットで調べたところ、こんなページを見つけました。

NEC製パソコン 画面が真っ暗! LL750/RG を修理する

おお、まさにこの現象だ。どうやら、PC-LL750RG には元々、アダプター繋いだ時のバックライト用のコンデンサーに問題があるようで、コンデンサーの経年劣化によりバックライトが点かなくなるらしい。

これ、バックライトの問題だと思う人、たくさんいるだろうなあ。

アダプター接続時のコンデンサーの問題なので、バッテリーで起動すると正常に表示されるっぽい。

つまりさっきバックライトが点いたのは、いろいろ触っているうちにバッテリーに充電されて、たまたまアダプターを外したまま起動したからっぽい。

試しに、アダプターを抜いてバッテリーだけで動かしたら、普通にバックライトが点いた状態で起動しました。

 

修理するためには、半田ごてを使ってマザーボード上のコンデンサーを物理的に新品に取り換える必要があり難易度高め。

部品代数百円なのにー!! ちなみに修理に出すと1万円ぐらいだろう。

メーカー修理だとマザー交換なんでとんでもない値段になるらしい。

 

Vistaパソコンにそこまで掛けられねーと思い、バッテリー起動なら普通に動くので、起動時にアダプターを抜いて、起動してからアダプターを差す運用で行くことにしました。

ってなことを何回か繰り返しているうちに、アダプター繋いだままでも普通に起動するようになりました。

訳わからないのですが、コンデンサーの蓄電状態により何らかの問題がでるのかもしれないなあ。

いずれにせよ、普通に使えるようになったので、よかったよかった。

 

で、このパソコンにUbuntuを入れたら問題が発生したので、それは次回書きます。

| | コメント (0)

« 2018年11月 | トップページ